شرح الاسكربت الرائع لفتح التصفح وسرعه تحميل البرامج والصيغ




الشرح

الاسكربت يعمل على النسخ 6 فقط ولا يعمل مع معظم الكيسه السيرفر
وجارى التعديل ليعمل على النسخ 5 

/ip firewall layer7-protocol
add name=L7_File regexp="\\.(exe|rar|zip|7z|cab|asf|mov|vob|wmv|mpg|mpeg|mkv|avi|flv|wav|rm|mp3|mp|ram|rmvb|dat|daa|iso|nrg|bin|vcd|3gp|aac|ace|aif|arj|bz2|gz|gzip|img|lzh|m4a|m4v|mpa|mpe|msi|msu|ogg|ogv|pdf|plj|pps|ppt|qt|ro*|r1*|ra|rm|sea|sit|sitx|tar|tif|tiff|z|001|002|003|004|005)"
add name=L7_Streaming regexp="videoplayback|video"
add name=L7_SpeedTest regexp="speedtest.3bb.co.th|speedtest.adslthailand.com|speedtest1.totbb.net|speedtest.net|speedtest.trueinternet.co.th|catspeedtest.net"
/
/
/ip firewall mangle
add action=mark-packet chain=postrouting layer7-protocol=L7_File new-packet-mark=File_PK passthrough=no disabled=no comment="Mark Packet Download File"

add action=mark-packet chain=postrouting protocol=tcp src-port=80,8080 connection-bytes=0-10000000 src-address-list=!SpeedTest_HOST dst-address-list=!SpeedTest_HOST new-packet-mark=HTTP_PK_DL passthrough=no disabled=no comment="Mark Packet HTTP"
add action=mark-packet chain=postrouting protocol=tcp dst-port=80,8080 connection-bytes=0-5000000 src-address-list=!SpeedTest_HOST dst-address-list=!SpeedTest_HOST new-packet-mark=HTTP_PK_UL passthrough=no disabled=no

add action=mark-packet chain=postrouting protocol=tcp src-port=443 src-address-list=!Streaming_HOST dst-address-list=!Streaming_HOST new-packet-mark=HTTPS_PK_DL passthrough=no disabled=no comment="Mark Packet HTTPS"
add action=mark-packet chain=postrouting protocol=tcp dst-port=443 src-address-list=!Streaming_HOST dst-address-list=!Streaming_HOST new-packet-mark=HTTPS_PK_UL passthrough=no disabled=no

add action=mark-connection chain=forward connection-mark=!Streaming_Conn new-connection-mark=Streaming_Conn layer7-protocol=L7_Streaming passthrough=no comment="Mark connection Streaming"
add action=add-src-to-address-list address-list=Streaming_HOST address-list-timeout=6h chain=prerouting connection-mark=Streaming_Conn
add action=mark-packet chain=postrouting src-address-list=Streaming_HOST new-packet-mark=Streaming_PK passthrough=no disabled=no comment="Mark Packet Streaming"

add action=mark-connection chain=forward connection-mark=!P2P_Conn new-connection-mark=P2P_Conn p2p=all-p2p passthrough=no comment="Mark connection P2P"
add action=add-src-to-address-list address-list=P2P-HOST address-list-timeout=1h chain=prerouting connection-mark=P2P_Conn
add action=mark-packet chain=postrouting src-address-list=P2P-HOST new-packet-mark=P2P_PK_DL passthrough=no comment="Mark Packet P2P"
add action=mark-packet chain=postrouting dst-address-list=P2P-HOST new-packet-mark=P2P_PK_UL passthrough=no

add action=mark-connection chain=forward connection-mark=!SpeedTest_Conn new-connection-mark=SpeedTest_Conn layer7-protocol=L7_SpeedTest passthrough=no comment="Mark connection SpeedTest"
add action=add-src-to-address-list address-list=SpeedTest_HOST address-list-timeout=50s chain=prerouting connection-mark=SpeedTest_Conn
/
/
/queue type
# ความเร็วดาวโหลดบิด ค่าปกติอยู่ที่ 512K และอัพโหลดอยู่ที่ 256K ต่อเครื่อง
add kind=pcq name=PCQ_P2P_DL pcq-rate=512K pcq-classifier=dst-address
add kind=pcq name=PCQ_P2P_UL pcq-rate=256K pcq-classifier=dst-address
# ความเร็วดาวโหลด ค่าปกติอยู่ที่ 5M ต่อเครื่อง
add kind=pcq name=PCQ_File pcq-rate=5M pcq-classifier=dst-address
# ความเร็วดู VDO ค่าปกติอยู่ที่ 8M ต่อเครื่อง
add kind=pcq name=PCQ_Streaming pcq-rate=8M pcq-classifier=dst-address
# ความเร็วเปิดเว็บ HTTP ดาวโหลดอยู่ที่ 6M และอัพโหลดอยู่ที่ 1M ต่อเครื่อง
add kind=pcq name=PCQ_HTTP_DL pcq-rate=6M pcq-classifier=dst-address
add kind=pcq name=PCQ_HTTP_UL pcq-rate=1M pcq-classifier=dst-address
# ความเร็วเปิดเว็บ HTTPS ดาวโหลดอยู่ที่ 6M และอัพโหลดอยู่ที่ 1M ต่อเครื่อง
add kind=pcq name=PCQ_HTTPS_DL pcq-rate=6M pcq-classifier=dst-address
add kind=pcq name=PCQ_HTTPS_UL pcq-rate=1M pcq-classifier=dst-address
/
/
/queue tree
add max-limit=10M name=1.QOS_P2P parent=global priority=8
add name=Download packet-mark=P2P_PK_DL parent=1.QOS_P2P queue=PCQ_P2P_DL priority=8
add name=Upload packet-mark=P2P_PK_UL parent=1.QOS_P2P queue=PCQ_P2P_UL priority=8

add max-limit=30M name=2.QOS_File parent=global priority=7
add name=File packet-mark=File_PK parent=2.QOS_File queue=PCQ_File priority=7

add max-limit=30M name=3.QOS_Streaming parent=global priority=2
add name=Streaming packet-mark=Streaming_PK parent=3.QOS_Streaming queue=PCQ_Streaming priority=2

add max-limit=40M name=4.QOS_Web parent=global priority=1

add max-limit=30M name=W_Download parent=4.QOS_Web priority=1
add name=1.HTTP_DL packet-mark=HTTP_PK_DL parent=W_Download queue=PCQ_HTTP_DL priority=1
add name=2.HTTPS_DL packet-mark=HTTPS_PK_DL parent=W_Download queue=PCQ_HTTPS_DL priority=1

add max-limit=10M name=W_Upload parent=4.QOS_Web priority=1
add name=1.HTTP_UL packet-mark=HTTP_PK_UL parent=W_Upload queue=PCQ_HTTP_UL priority=1
add name=2.HTTPS_UL packet-mark=HTTPS_PK_UL parent=W_Upload queue=PCQ_HTTPS_UL priority=1
/
/
/











تنويه : الصور والفيديوهات في هذا الموضوع على هذا الموقع مستمده أحيانا من مجموعة متنوعة من المصادر الإعلامية الأخرى. حقوق الطبع محفوظة بالكامل من قبل المصدر. إذا كان هناك مشكلة في هذا الصدد، يمكنك الاتصال بنا من هنا.

عن الكاتب

هذا النص هو مثال لنص يمكن أن يستبدل في نفس المساحة، لقد تم توليد هذا النص من مولد النص العربى

0 التعليقات لموضوع "شرح الاسكربت الرائع لفتح التصفح وسرعه تحميل البرامج والصيغ"


الابتسامات الابتسامات